Page 1 of 1

OpenLCA 1.4.1 beta 6 possible bug

Posted: 15 Jan 2015 13:19
by chrisf
Hi, I'm working with v1.4.1 beta-6 in Windows 7 Pro. Software generally works fine. I've set up one input to a process using a parameter and dependent parameter to allow me to vary the proportion of this raw material coming from two alternatives sources (or swap from one to the other) but always keep the same total input. That works fine at the unit process level. When I change the value at the product system level and re-calculate the system, an error occurs ("calculation failed"). If I close OpenLCA and re-open the new parameter values are established and the system calculates fine. Is this a minor bug or am I doing something wrong?

Re: OpenLCA 1.4.1 beta 6 possible bug

Posted: 20 Jan 2015 11:15
by SWinter
Hi chrisf,
I created a test process with one input for which the amount contains two parameters, one local + one global. I set the parameters on the process level, then created a product system and changed the values. I tried a number of different things but I wasn't able to recreate any errors, I could calculate the product system without any problems. If you change the parameter values on the product system level and don't save before you calculate, the new values won't be taken into account but the calculation should still work anyway. Are you still having this problem?
Best greetings,

Re: OpenLCA 1.4.1 beta 6 possible bug

Posted: 21 Jan 2015 08:42
by msrocka
Hi, I tried to reproduce this but redefining process parameters at the product system level works without any error in my test cases. Do you have a simple example how this can be reproduced (maybe also a small database or ILCD package you can share)?

Thank you very much,

Re: OpenLCA 1.4.1 beta 6 possible bug

Posted: 27 Jan 2015 17:04
by chrisf
Michael, Sarah,
I'll try to generate a small case study and send it over when I get a chance. Could be just me/ my pc / my antivirus software!
Best wishes,