Page 1 of 1

Improper field population

Posted: 12 Jun 2014 17:17
by ZacC
Hello All,

I have not been able to get two fields to properly populate in openLCA 1.4.0 Beta 3. I am using openlca-1.4.0_BETA_3.20140124-win-64bit downloaded on April 17, 2014.

End date field (on General information tab): The format of the field is MM/DD/YYYY. I am trying to set DD to "31" (i.e. "12/31/2008"). After setting DD to "31" I save the file and close it; however, when I reopen the file, DD is always reset to the current day of the month. For example, on June 12, 2014, the DD always resets to 12. The MM and YYYY portions of the field seem to be working properly.

Creation date field (on Administrative information tab: The creation date field is not accessible to me. Please see the screenshot below:
Creation date field cannot be populated
CreationDateField.JPG (16.11 KiB) Viewed 2978 times
How can I access the creation date field to modify it?

Any suggestions would be appreciated. Thanks very much,


Re: Improper field population

Posted: 13 Jun 2014 15:17
by aciroth
Hello Zac,
the end date fields has been fixed meanwhile in the beta 7 version, see screenshot below (for my German operation system; in English language the date will be different but the calendar element is the same). The creation date field is for documentation only and filled automatically.
2014-06-13 14_51_22-openLCA 1.4 (beta 7).png
2014-06-13 14_51_22-openLCA 1.4 (beta 7).png (11.25 KiB) Viewed 2975 times
The beta 7 version is available here: ... ac2a202437

Final release of the non-beta version will be next week.


Re: Improper field population

Posted: 13 Jun 2014 23:23
by ZacC

Thank you for your helpful reply. I have one more follow-up question.

For inputs and outputs in a process, openLCA is not consistent in recognizing and saving changes in the Pedigree Uncertainty field. That is, when I modify the Pedigree uncertainty field sometimes openLCA recognizes the change and gives me the option to save the updated process (as indicated by an asterisk next to the process name on the top tab, please see screenshot below):
Notice the asterisk next to the process name
UnitProcessChange.JPG (8.48 KiB) Viewed 2971 times
However, other times openLCA does not recognize the change in the Pedigree uncertainty field and, consequently, I am unable to save the change. Can you offer any suggestions?

Thanks very much,


Re: Improper field population

Posted: 30 Jun 2014 00:44
by aciroth
Hi Zac,
indeed, this behaviour was an issue in the beta versions and is fixed in the released non-beta version.
Best wishes, thanks,