Page 1 of 1

Cannot create a Database

Posted: 02 Mar 2011 12:03
by luisferldeo

I've been working with open LCA for the last four months, everything was going well. Then I decided to check out the new non-beta version. It turns out that my work was not imported. Even worse, I followed the steps (MySQL connection) but when I tried to create a new database... nothing happens. A database is not created, so I can't even start working. Furthermore I tried to go to the old version but it apparently is not available anymore. Do you have any suggestions?

Thanks for your help


Re: Cannot create a Database

Posted: 05 Mar 2011 07:33
by aciroth
Hi Luis,
a reason might be that the MySQL server cannot start or is blocked - you can try to connect to the server over a different port (not 3306 but e.g. 3305). This may happen due to a firewall setting or if you have another MySQL server running. The user interface is currently showing a connection to the MySQL server even if it is blocked. We have fixed this (see also the fixed bug in the bug tracker at the sourceforge site, 'No error message when start of MySQL server fails', ... tid=928543), and will release this renewed version next week.
The old versions are available still, here: ... framework/, under beta 1.1.1 and so on.
Can you please respond if this solved your problem?

Re: Cannot create a Database

Posted: 09 Mar 2011 10:39
by luisferldeo
thanks for your answer Andreas,

Nevertheless I still cannot create a database (thus start working). For the moment I've been working with the old version. But I've tried all the tips: I've closed the old OpenLCA and restarted the computer, to avoid having an active connection; but without succes. I've also deactivated the windows 7 firewall and I also interrupted my antivirus (I'm using Avira, if it helps). No success either.

I was wondering, is there a way to "cheat" the program and instead of creating a new database, instruct the program to connect to my already existing database on the beta 1.1 version?

If not maybe I'll just wait for the next week's version you've mentioned.

Again, thanks for your help, and (it's worth to mention) for the whole openLCA


Re: Cannot create a Database

Posted: 17 May 2011 16:07
by luisferldeo
Hello Andreas,

I've started to work with the non-beta version and I'm enjoying it. But yet another detail showed up. I finished my previous project with the beta version and decided to start working with the new one. Everything was running smoothly, I imported ecoinvent without major problems and even did a couple of product system's analysis (two thumbs up on the sankey diagram and other functions by the way).

The problem, again, is related to the MySQL server. On the new version I used the default settings because it was the only way I could create databases. I suppose it was so because I was using the same data provider with the previous version. The problem is that if I create a new MySQL connection with the "embedded" function later on I cannot connect to it because I get an error message (see under), and if I don't choose it to be embedded then I can't create any databases.

This is the message I get

[quote][/quote]An unexpected error occurred
Could not start embedded server:
(with an error report that opens in my browser that says)
org.openlca.core.dataprovider.DataProviderException: Could not start embedded server:
at org.openlca.core.database.MySQLServer.start(
at org.openlca.core.application.actions.ConnectDataProviderAction.task(
at org.openlca.core.application.actions.NavigationAction$
at org.eclipse.jface.operation.ModalContext$
Caused by: java.lang.Exception: Could not start embedded server:
at org.openlca.core.database.MySQLServer.startEmbeddedServer(
at org.openlca.core.database.MySQLServer.start(

Then all the data I have is on the localhost:3306 (default). Yet the only way to access it (on the openLCA framework 1.2) is if I start the beta version first. Is there a way I can work with the openLCA framework 1.2 without the need to open the "old" OpenLCA? It is not such a big deal but I suppose this update is not supposed to be dependent on the previous one to work.

I'm working with Mac OSX and I've installed the application in system preferences called MySQL server status but still, every time I try to open an embedded connection I get the same message.

Thanks for your help and best regards


Re: Cannot create a Database

Posted: 07 Oct 2011 21:41
by qwweeeit
I'm trying to install the 1.2.4 version of OpenLCA, but I run into the same problem of luisferldeo.
Please find attached the error message log.

Can someone help us?
Thanks in advance

Re: Cannot create a Database

Posted: 11 Oct 2011 20:29
by qwweeeit
The problem was MySQL service because the embedded connection didn't start.
Therefore I've installed MySQL server and then I've created from openLCA a new MySQL connection as non-embedded, that is without the flag on "embedded" checkbox. In such a way, you can connect to MySQL so you can create a new database. Afterwards you can import the impact methods as Aciroth explained in another post.